ID CVE-2021-31162
Summary In the standard library in Rust before 1.53.0, a double free can occur in the Vec::from_iter function if freeing the element panics.
References
Vulnerable Configurations
  • cpe:2.3:a:rust-lang:rust:1.48.0:*:*:*:*:*:*:*
    cpe:2.3:a:rust-lang:rust:1.48.0:*:*:*:*:*:*:*
  • cpe:2.3:a:rust-lang:rust:1.49.0:*:*:*:*:*:*:*
    cpe:2.3:a:rust-lang:rust:1.49.0:*:*:*:*:*:*:*
  • cpe:2.3:a:rust-lang:rust:1.50.0:*:*:*:*:*:*:*
    cpe:2.3:a:rust-lang:rust:1.50.0:*:*:*:*:*:*:*
  • cpe:2.3:a:rust-lang:rust:1.51.0:*:*:*:*:*:*:*
    cpe:2.3:a:rust-lang:rust:1.51.0:*:*:*:*:*:*:*
  • cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*
    cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*
  • cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*
    cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*
  • cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*
    cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*
CVSS
Base: 7.5 (as of 27-04-2021 - 14:36)
Impact:
Exploitability:
CWE CWE-415
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:P/I:P/A:P
Last major update 27-04-2021 - 14:36
Published 14-04-2021 - 07:15
Last modified 27-04-2021 - 14:36
Back to Top