ID CVE-2019-14866
Summary In all versions of cpio before 2.13 does not properly validate input files when generating TAR archives. When cpio is used to create TAR archives from paths an attacker can write to, the resulting archive may contain files with permissions the attacker did not have or in paths he did not have access to. Extracting those archives from a high-privilege user without carefully reviewing them may lead to the compromise of the system.
References
Vulnerable Configurations
  • cpe:2.3:a:gnu:cpio:-:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:-:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:1.0:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:1.1:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:1.2:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:1.2:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:1.3:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:1.3:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:2.4-2:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:2.4-2:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:2.5:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:2.5:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:2.5.90:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:2.5.90:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:2.6:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:2.6:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:2.7:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:2.7:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:2.8:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:2.8:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:2.9:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:2.9:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:2.10:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:2.10:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:2.11:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:2.11:*:*:*:*:*:*:*
  • cpe:2.3:a:gnu:cpio:2.12:*:*:*:*:*:*:*
    cpe:2.3:a:gnu:cpio:2.12:*:*:*:*:*:*:*
  • cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:*
    cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:*
  • cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:*
    cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:*
CVSS
Base: 6.9 (as of 10-01-2020 - 14:27)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
LOCAL MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
cvss-vector via4 AV:L/AC:M/Au:N/C:C/I:C/A:C
redhat via4
advisories
bugzilla
id 1765511
title CVE-2019-14866 cpio: improper input validation when writing tar header fields leads to unexpect tar generation
oval
OR
  • comment Red Hat Enterprise Linux must be installed
    oval oval:com.redhat.rhba:tst:20070304026
  • AND
    • comment Red Hat Enterprise Linux 7 is installed
      oval oval:com.redhat.rhba:tst:20150364027
    • comment cpio is earlier than 0:2.11-28.el7
      oval oval:com.redhat.rhsa:tst:20203908001
    • comment cpio is signed with Red Hat redhatrelease2 key
      oval oval:com.redhat.rhsa:tst:20152108002
rhsa
id RHSA-2020:3908
released 2020-09-29
severity Moderate
title RHSA-2020:3908: cpio security update (Moderate)
rpms
  • cpio-0:2.11-28.el7
  • cpio-debuginfo-0:2.11-28.el7
refmap via4
confirm https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14866
misc
Last major update 10-01-2020 - 14:27
Published 07-01-2020 - 17:15
Last modified 10-01-2020 - 14:27
Back to Top