ID CVE-2021-33289
Summary In NTFS-3G versions < 2021.8.22, when a specially crafted MFT section is supplied in an NTFS image a heap buffer overflow can occur and allow for code execution.
References
Vulnerable Configurations
  • cpe:2.3:a:tuxera:ntfs-3g:2009.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2009.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2009.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2009.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2009.3.8:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2009.3.8:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2009.4.4:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2009.4.4:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2009.11.14:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2009.11.14:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2010.1.16:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2010.1.16:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2010.3.6:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2010.3.6:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2010.5.16:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2010.5.16:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2010.5.22:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2010.5.22:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2010.8.8:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2010.8.8:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2010.10.2:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2010.10.2:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2011.1.15:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2011.1.15:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2011.4.12:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2011.4.12:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2012.1.15:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2012.1.15:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2013.1.13:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2013.1.13:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2014.2.15:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2014.2.15:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2015.3.14:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2015.3.14:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2016.2.22:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2016.2.22:*:*:*:*:*:*:*
  • cpe:2.3:a:tuxera:ntfs-3g:2017.3.23:*:*:*:*:*:*:*
    cpe:2.3:a:tuxera:ntfs-3g:2017.3.23:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*
CVSS
Base: 6.9 (as of 25-09-2021 - 01:15)
Impact:
Exploitability:
CWE CWE-787
CAPEC
Access
VectorComplexityAuthentication
LOCAL MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
cvss-vector via4 AV:L/AC:M/Au:N/C:C/I:C/A:C
Last major update 25-09-2021 - 01:15
Published 07-09-2021 - 14:15
Last modified 25-09-2021 - 01:15
Back to Top